Just Trying to get servos to move

This is the place for troubleshooting products! Do you have a common ground? Is that a dry joint? This is where we'll sort it!
lesmg
Mostly Harmless
PostsCOLON 4
JoinedCOLON Mon Jan 27, 2014 12:34 pm

Just Trying to get servos to move

Postby lesmg » Mon Jan 27, 2014 2:20 pm

Hi All, I am just trying to get some movement out of my servos, I can see that the software and comms to I2c are fine as I can read and write registers, but cannot get servo movement.

wired up as per

http://learn.adafruit.com/system/assets ... 1345136644

and my soldering is attached but had it checked by guy at work and looks ok ish

IMG_2207.JPG
You do not have the required permissions to view the files attached to this post.

phenoptix
Competent
PostsCOLON 745
JoinedCOLON Sat Apr 17, 2010 11:25 am

Re: Just Trying to get servos to move

Postby phenoptix » Mon Jan 27, 2014 2:26 pm

I think you might have a couple of dry joints there. The one top middle looks like it could be your problem as it's your power connector
DryJoints.png
You do not have the required permissions to view the files attached to this post.

lesmg
Mostly Harmless
PostsCOLON 4
JoinedCOLON Mon Jan 27, 2014 12:34 pm

Re: Just Trying to get servos to move

Postby lesmg » Mon Jan 27, 2014 2:47 pm

Its not the best pic I know, but they look fine

lesmg
Mostly Harmless
PostsCOLON 4
JoinedCOLON Mon Jan 27, 2014 12:34 pm

Re: Just Trying to get servos to move

Postby lesmg » Mon Jan 27, 2014 3:05 pm

I'll try re-soldering

but I also found this

http://forums.adafruit.com/viewtopic.ph ... 30#p183964

lesmg
Mostly Harmless
PostsCOLON 4
JoinedCOLON Mon Jan 27, 2014 12:34 pm

Re: Just Trying to get servos to move

Postby lesmg » Tue Jan 28, 2014 3:57 am

Hmmm got it working, nothing wrong with board, or pi, when I originally tried to control the board I tried using python

bus = smbus.SMBus(1)

bus.write_byte_data(0x40,0x00,0xff)

little like I did with my SPI board, this is why I could not get servos to move

using this

http://www.raspberry-projects.com/pi/pr ... nterface-2

WIERD!


Return to

Who is online

Users browsing this forum: 1 and 0 guests